Products

Solutions

Learn More

Partners

Community

Blog

About

New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsWikiWikiIssues in IE with <li>'s' />Issues in IE with
  • 's and
    's
  • Previous
     
    Next
    New Post
    6/29/2009 10:36 AM
     

    We have been using the wiki lately and have noticed some strange behaviour when we try to enter in unordered lists and ordered lists into our page. It seems that after every <li> it wants to insert a <br/> of course we don't want the <br/> to be inserted because the </li> tags automatically break to the next line. Has anyone else had this issue? This might be an issue with the FCKHtmlEditorProvider but I've only noticed it in the wiki so far.

    Any help is greatly appreciated. Thanks!

     
    New Post
    6/29/2009 11:37 AM
    Accepted Answer 

    I think I found the solution.

    If you open /Providers/htmlEditorProviders/Fck/Custom/fckconfig.js and look around like 81 you should find an entry 'FCKConfig.formatOutput' it should be set to true by default. If you are having the same issue as I am to where it is inserting line breaks where you don't want them to be on save go ahead and set this to false and it should solve the problem. So far in the quick tests I've done it has helped tremendously.

    Seems like they have natural line breaks being replaced with the br tag on save as well as Enter keyboard strokes being replaced with nothing. So far I haven't found any adverse effects to turning this feature off. I'll post any if I find them.

     
    New Post
    6/29/2009 11:43 AM
     

    this helps a ton!  thanks!

     
    New Post
    6/30/2009 11:55 AM
     

    This is actually a bug in the Wiki module that has been corrected. I'm hoping to get a new package together here in the next week or so to try to get a release going.


    Chris Hammond
    Former DNN Corp Employee, MVP, Core Team Member, Trustee
    Christoc.com Software Solutions DotNetNuke Module Development, Upgrades and consulting.
    dnnCHAT.com a chat room for DotNetNuke discussions
     
    Previous
     
    Next
    HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsWikiWikiIssues in IE with <li>'s' />Issues in IE with
  • 's and
    's


    These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

    For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

    1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
    2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
    3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
    4. No Flaming or Trolling.
    5. No Profanity, Racism, or Prejudice.
    6. Site Moderators have the final word on approving / removing a thread or post or comment.
    7. English language posting only, please.

    Content Layout

    Subscribe to DNN Digest

    Subscribe to DNN Digest

    DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  

    What is Liquid Content?
    Find Out
    What is Liquid Content?
    Find Out
    What is Liquid Content?
    Find Out