Products

Solutions

Learn More

Partners

Community

Blog

About

New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Upgrading DNN P...Upgrading DNN P...Site setting & Navigation Problem in sub sitesSite setting & Navigation Problem in sub sites
Previous
 
Next
New Post
3/27/2019 2:19 AM
 

Hi,

After upgrading dnn 9.1.1 or 9.2.2, I faced a same problem regarding to the navigation & page links. 

I have multiple product sites under the main site. Once i tried to create a page under my product sites the page link redirect it to the main site. 

Example: 

localhost:81 (Main portal is running)

localhost:81/productsite (Individual Product Site with in Mian portal)

Once, I made "Test Page" under  localhost:81/productsite it link me to localhost:81/TestPage instead of  localhost:81/productsite/TestPage. 

Any one have any idea how can I fixed this issue 

Note: This problem arrives only with top level navigation sub navigation are working fine

 
New Post
3/27/2019 7:14 AM
 
Rashid,

I am not sure if you are really talking of sites or pages, but my impression is that there is something wrong with the Urls.

So if you really have set up a sub-portal then you should make sure, that in the portal settings there are the correct HTTP Aliases are set in the portal settings. For the sub-portal this should be localhost:81/productsite when I interpret your post correctly.

Happy DNNing!
Michael

Michael Tobisch
DNN★MVP

dnn-Connect.org - The most vibrant community around the DNN-platform
DNN Connect 2020
 
New Post
3/27/2019 8:30 AM
 

Thanks for your reply Michal, I am talking about the pages. The sub portal has proper alias settings "http://localhost:81/product".

The URL working fine, once i update any thing in site setting section even just open the site setting page and click save each page link works fine. 

Once i update any thing in the page setting the page again lost the URL and respective position. After update any thing in page setting the page URL pointing back to main portal and automatically move to last position 

 
New Post
3/27/2019 9:24 AM
 
Rashid,

did you check the Url foor the parent page?

Happy DNNing!
Michael

Michael Tobisch
DNN★MVP

dnn-Connect.org - The most vibrant community around the DNN-platform
DNN Connect 2020
 
New Post
3/27/2019 1:32 PM
 

Yes i checked it out, i downgrade it for 9.0.0 it's working fine there. there is a bug in it

 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Upgrading DNN P...Upgrading DNN P...Site setting & Navigation Problem in sub sitesSite setting & Navigation Problem in sub sites


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out