Products

Solutions

Resources

Partners

Community

About

New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeGetting StartedGetting StartedInstalling DNN ...Installing DNN ...DNN 9 on aure - Getting 404 error for every pageDNN 9 on aure - Getting 404 error for every page
Previous
 
Next
New Post
12/27/2017 6:13 PM
 
Hi everyone,

We are trying one of our web sites on azure.

The site displays without any problem.
When we try to show it with the tabId, it is working fine.
But, if we try to open it with its seo url, we have the 404 error page.

My understanding is that the url rewrite module is not working fine.
Any suggestions ?

Many thanks by advance.
 
New Post
12/28/2017 12:11 AM
 
Have you made any changes to the web.config? 

Does your FriendlyURL section of the config look like this?

    <friendlyUrl defaultProvider="DNNFriendlyUrl">
      <providers>
        <clear />
        <add name="DNNFriendlyUrl" type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" urlFormat="advanced" />
      </providers>
    </friendlyUrl>

Chris Hammond
Former DNN Corp Employee, MVP, Core Team Member, Trustee
Christoc.com Software Solutions DotNetNuke Module Development, Upgrades and consulting.
dnnCHAT.com a chat room for DotNetNuke discussions
 
New Post
12/28/2017 12:23 AM
 
Hi,

Yes this is exactly what I have in the web.config.
It is working on my server with IIS7 but not on azure.
Should I modify something to make it work on azure web app?

Many thanks by advance for your help.
 
New Post
12/28/2017 3:08 AM
 
Ali,
I don't think you need to modify anything specifically to get it working on Azure. I have a DNN 9 app running without any problems there. It's been a while since I set it up, but I don't recall having to configure anything specifically for URLs.

On the Application Settings, here's a quick rundown of what I have configured, perhaps it will help.

.Net Framwork: V4.7
PHP/Java: Off
Python Version: Off
Platform: 32bit
Web Sockets: On
Always on: Off
Managed Pipeline Version: Integrated
ARR Affinity: On




Chris

Chris Hammond
Former DNN Corp Employee, MVP, Core Team Member, Trustee
Christoc.com Software Solutions DotNetNuke Module Development, Upgrades and consulting.
dnnCHAT.com a chat room for DotNetNuke discussions
 
Previous
 
Next
HomeHomeGetting StartedGetting StartedInstalling DNN ...Installing DNN ...DNN 9 on aure - Getting 404 error for every pageDNN 9 on aure - Getting 404 error for every page


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out