Learn More





Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Profile Image Won't LoadProfile Image Won't Load
New Post
9/25/2015 11:35 PM

I'm running DNN 7.4.1 on localhost and just can not get the profile image to load.  If I drag an image onto the "Drop  Files here" box, the image will copy to the correct users folder but the profile image will still show the default image.  If  I click the file selection drop down, all text elements say "undefined" and a little rotating "working" icon spins forever.   Even if I manually put the image in the correct folder and then go into the UserProfile table and enter the file name in the Avatar column, it STILL won't render on the screen.   I'm assuming the profile image is what Active Forums also uses as the avatar, since Active Forums no longer has an avatar uploader in its user preference page like it did in the past.  The images are not appearing in the forum either though.  I'm trying to port a site over from DNN 5 and am stuck on this.  Anyone know the solution?  Maybe it is something specific to running on localhost?  I noticed there is a bug in ActiveForums where the auto-generated URLs to images embedded in the post will use only "localhost" when the real URL requires something like "localhost:34004", thus breaking all the images in the forum posts.  Maybe this profile image thing is caused by a similar botching of the URL?


New Post
9/26/2015 12:00 AM
Update: the user profile property number 21, which is the ID of the profile image, has its PropertyValue set to -1 after updating. I'm assuming this would normally be the file name, but if I manually enter the file name I still don't get the image to show up in the profile.  I only entered just the file, no path of any sort.  Since I can't create a functional profile image to look at as an example, I have no idea what the data is supposed to look like for one that is working.
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Profile Image Won't LoadProfile Image Won't Load

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
Try Evoq
For Free
Start Free Trial
a Demo
See Evoq Live
Need More Information?