Learn More





Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Force use of Https for settings and edit content windowsForce use of Https for settings and edit content windows
New Post
1/2/2015 1:42 PM

Good afternoon everyone,

 I am using DNN on a site that only accepts https requests. However DNN always prepends any administrative task links with http instead of https, thus casing a security warning. For instance when I am in Edit view I can click Edit page >> Page settings but this produces a mixed content warning to which I must reply with "show all content" then click Edit page >> page settings again before I can edit any page. This becomes very annoying when doing simple tasks like editing HTML modules on a page or configuring any kind of setting.

I never told DNN this was an HTTPS site (or that it was HTTP for that matter) but it assumes http and this causes a problem. Where can I configure this setting to always prepend the admin task links with HTTPS?


New Post
1/2/2015 2:40 PM

Have you configured the Secure settings in the Host/Host Settings?


Chris Hammond
Former DNN Corp Employee, MVP, Core Team Member, Trustee Software Solutions DotNetNuke Module Development, Upgrades and consulting. a chat room for DotNetNuke discussions
New Post
1/7/2015 11:35 AM
I guess I have not. I don't have Secure settings under host/host settings
New Post
1/8/2015 9:54 AM
Which DNN version are you using? some images might still be using http instead of https, there had been a fix around DNN version 7.3.2

Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group   European Network of DotNetNuke Professionals

Speed up your DNN Websites with TurboDNN
New Post
1/8/2015 10:07 AM
I have version 7.03.04.

I have found the problem. The site is behind a firewall and though the request is" https"  HttpContext.Current.Request.IsSecureConnection returns false because of the way the request is handled by the firewall and server. Thus DNN.Globals AddHTTP function writes the URLs to the page as http, thus confusing the browsers.

I have handled it with a crude hack by modifying the OnPreRender function in ModuleActions.ascx.cs file to include the code below within the foreach action statement..

 if (action.Url.ToLower().Contains(PortalSettings.PortalAlias.HTTPAlias))

                                            action.Url = action.Url.Replace("http://", "https://");

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Force use of Https for settings and edit content windowsForce use of Https for settings and edit content windows

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
Try Evoq
For Free
Start Free Trial
a Demo
See Evoq Live
Need More Information?