Learn More





Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Tip: Turn off "Website Links" in HTML EditorTip: Turn off "Website Links" in HTML Editor
New Post
9/11/2013 11:54 AM

Hi everybody,

I found this yesterday and thought I'd pass it along in case it would help others. All of our pages that used the standard DNN text editor control took an extra 1-2 seconds to load. I found this when traced the slowdowns to the PageLoad event and, from there, to the text editor. 

The text editor, by default, has a list of "Custom Links" and DNN fills it in with the links to pages on your site. Our site, though, has around 500 pages, and it was taking the text editor that long to build the list. Fortunately, that's a setting in the HTML Editor Manager accessible by the host account. When we turned off "Show Website Links", the slow downs went away entirely. 

This has really improved the usability for our staff. There were all kinds of things - like the News Articles module, for instance, that we thought just ran really poorly... it turned out it was all that editor. Any page where the editor was used took a long time. 

Actually, the improvement has been so dramatic that I would recommend DNN turn it off by default. I would guess that subtlety slows down many sites out there. The speed increase for editing content was tremendous... I always just thought DNN was slow.

Hope this helps,


New Post
9/11/2013 1:32 PM
Where do you turn that setting off?
New Post
9/11/2013 2:22 PM

You have to log in as the host... Then, go to "Host" > (Advanced Settings) > "HTML Editor Manager"

From there, you click on the "Everyone" profile and you'll see the settings for the text editor.

New Post
9/12/2013 4:08 AM
alternatively switch to ckeditor (

Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group   European Network of DotNetNuke Professionals

Speed up your DNN Websites with TurboDNN
New Post
9/12/2013 9:10 AM
That page was so weird (a pulldown with "dotnetnul" as only value, switching doesn't work), I thought that was broken...
Clicking the "everyone" in the tree view brings up a whole load of settings. I've definitly not been here before and I'm the only admin. The "Show Website Links" was already off, on all my hosts. I guess it is default off.
Damn... no performance boost for me.

I started with DNN 7.0.2, maybe it's on when you come from an earlier version? Or default on when you start at a later version?
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Tip: Turn off "Website Links" in HTML EditorTip: Turn off "Website Links" in HTML Editor

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
Try Evoq
For Free
Start Free Trial
a Demo
See Evoq Live
Need More Information?