Learn More





Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ..."Add New Role" button does nothing."Add New Role" button does nothing.
New Post
7/2/2013 7:39 PM


I was wondering if anyone else has had any trouble with the "Add New Role" or "Add new role group" buttons under "Admin"-> "Security Roles" in DNN 7.00.06?  I've installed two separate installations (fresh, no upgrade) and on both sites, these buttons do nothing.  I've tried different computers, browsers, and host to admin accounts, but I can't get then to do anything.  The rest of the site works fine (all other functionality works).

The only thing these two installations have in common, is that they are using the same skin, and they are hosted on the same server.  Other than that, they have their own databases, application pools, etc.

Is this a bug, or am I just missing something that needs to be enabled to be able to add new security roles?  If it is a bug, is there a manual way to add new roles?



New Post
7/3/2013 5:56 AM
Hi Kevin
Probably u missed something on installation as i am facing no problem in this.
You can check the DesktopModules\Admin\Security\roles.ascx file for the button and check the necessary code behind present or not.

Sunil Kumar [ DNN Developer, Mindfire Solutions,India ]
New Post
7/6/2013 1:07 AM

Now this issue is affecting the "Update" button on the "Site Settings" page....on both sites!  This is super-strange.  I'm sure that installed the sites properly.  They were completely fresh installs and I used the wizard to complete them.   This is the current code for the update button:

<a id="dnn_ctr442_SiteSettings_cmdUpdate" title="Update" class="dnnPrimaryAction" href=' WebForm_DoPostBackWithOptions(new WebForm_PostBackOptions("dnn$ctr442$SiteSettings$cmdUpdate", "", true, "", "", false, true))'>Update</a>

It seems fine, but it's not firing anything.



New Post
7/6/2013 3:31 AM
most likely there is some issue with client side code, turn on script errors in your browser settings to get displayed details.

Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group   European Network of DotNetNuke Professionals

Speed up your DNN Websites with TurboDNN
New Post
7/19/2013 12:42 PM
Just wanted to update this thread with the cause of the problem (in case anyone else has this issue in the future). I had a contact form located in the footer and I had set it to display on all pages (which apparently was a bad idea). Therefore the contact form was being displayed on all the admin pages as well and the form submit was somehow causing an issue with other form submits on the same page (not sure why or how exactly). So I removed the form from all the admin pages and it solved my problem. This may come up as another issue if I have a form on a page where I may want to keep the contact form in the footer of that same page. I'll cross that bridge when I get there, I guess.
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ..."Add New Role" button does nothing."Add New Role" button does nothing.

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
Try Evoq
For Free
Start Free Trial
a Demo
See Evoq Live
Need More Information?