Products

Solutions

Learn More

Partners

Community

Blog

About

New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Digital Asset Management failingDigital Asset Management failing
Previous
 
Next
New Post
5/10/2019 3:58 PM
 

Our production File Manager page started failing two days ago with the following error:

Error: Digital Asset Management is currently unavailable. DotNetNuke.Services.Exceptions.ModuleLoadException: Sequence contains more than one matching element ---> System.InvalidOperationException: Sequence contains more than one matching element at System.Linq.Enumerable.Single[TSource](IEnumerable`1 source, Func`2 predicate) at DotNetNuke.Modules.DigitalAssets.Services.Factory.get_DigitalAssetsController() at DotNetNuke.Modules.DigitalAssets.View..ctor() at ASP.desktopmodules_digitalassets_view_ascx..ctor() at __ASP.FastObjectFactory_app_web_l5faym1v.Create_ASP_desktopmodules_digitalassets_view_ascx() at System.Web.UI.TemplateControl.LoadControl(IWebObjectFactory objectFactory, VirtualPath virtualPath, Type t, Object[] parameters) at System.Web.UI.TemplateControl.LoadControl(VirtualPath virtualPath) at DotNetNuke.UI.ControlUtilities.LoadControl[T](TemplateControl containerControl, String ControlSrc) at DotNetNuke.UI.Modules.WebFormsModuleControlFactory.CreateModuleControl(TemplateControl containerControl, ModuleInfo moduleConfiguration) at DotNetNuke.UI.Modules.ModuleControlFactory.LoadModuleControl(TemplateControl containerControl, ModuleInfo moduleConfiguration) at DotNetNuke.UI.Modules.ModuleHost.LoadModuleControl() --- End of inner exception stack trace ---

This is on a DNN PLATFORM v09.02.01 (533) build.

In a test environment reproduced the error with a fresh database and file system restore from production. Upgrading this test environment to the new v09.03.02 release did not fix the issue. (Nor did it remove Manage > File Manager and add Content > Assets to the persona bar.)

Searching this error, I see several other posts with the same error but not with a resolution. I have searched dbo.Files and dbo.Folders for any apparent duplicates, and I don't see any. I also tried deploying some code to the test environment to force a FolderManager.Instance.Synchronize(), which ran without error but also did not correct the error.

At this point our production site admins have no way to manage site content. Can anyone recommend where I need to look to resolve this error?

 
New Post
5/10/2019 4:17 PM
 

Hi,

If i look in the dnn source code, it sound like as a duplicate IDigitalAssetsController.

This is in my eyes duplicate code in memory.

I suggest you to search in the bin folder (or somewhere else) for a duplicate dll or old dll corresponding with the asset manager or file manager.

And try to remove them. (sure make a backup first )

Not sur it's the real issue, but something to look for...

Sacha

 
New Post
5/11/2019 7:25 PM
 
Apparently the underlying issue is that there is more than one digital asset controller somehow. I pulled the DNN source, compiled a debug version of the DigitalAssets module, and identified the exception at Services > Factory.cs line 49. When I changed it from:

return dac != null ? dac.Value : controllers.Single(c => c.Metadata.Edition == "CE").Value;

to:

return dac != null ? dac.Value : controllers.First(c => c.Metadata.Edition == "CE").Value;

The error went away and the module loaded correctly. Obviously I can't deploy this to production, or at least I would really prefer not to.

So question number one is: Where are the controllers actually installed at? How can I find and remove the extra unexpected digital asset controller?
Question number two is: Is this a legitimate bug, and should I submit a pull request making the change? I suspect not, but I feel like the code is making a bad assumption and it should handle it more gracefully.
 
New Post
5/12/2019 3:08 AM
 
Well, I think the problem is that there are two of them, was this by any chance an Evoq installation that got migrated to the Community Edition?
 
New Post
5/12/2019 6:07 AM
 
No, this has only ever been a community edition, upgraded continuously since version 4. And yes, the explicit problem is that there are now two digital asset controllers. So where did the second one come from, and how do I remove it? The problem started happening spontaneously last week, but no upgrade or new modules have been installed recently.
 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Digital Asset Management failingDigital Asset Management failing


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  

What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out