New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...SSL website under F5 with VIPSSL website under F5 with VIP
New Post
11/22/2018 1:40 PM


I implemented a new DNN Platform website and my system administrator decided to use SSL with F5 VIP. Therefore, I do not need to add certificate under my IIS Server. In addition, I do not need to enable SSL in DNN Security Settings. How that supposed works:

  • The DNN website IIS Server is only running HTTP service on port 80.
  • The client is connecting to the VIP on F5 on port 443 (HTTPS).
  • The VIP on F5 is listening on port 443 (HTTPS), the SSL certificate is install on the F5 VIP.
  • The F5 will forward the request to the server of the IIS website on port 80 unencrypted.
  • Response from the server of the DNN IIS website is encrypted by F5 then send it to the client.

For now, my entire website pages show correctly with https included the DNN Persona Bar options. But, if I’m going to the Edit Mode to edit content of a Html Module or going to the Settings of a module, the popup windows open but showing indefinitely the progress icon. The console of the browser give me the error: “Mixed Content: The page at '' was loaded over HTTPS, but requested an insecure resource ''. This request has been blocked; the content must be served over HTTPS.”

To resolve, I activated the DNN setting SSL Enable and I switched to "On" the Secure Connection setting of the Home page. If I do that, the browser return me the error "Too Many Redirects" and the page cannot showing.

What I can do? My old DNN Platform website had his own certificate directly under IIS of the website server with port 443 but not this new one.

Thanks for your help!

Just for you know... The new website version is DNN Platform v9.2.2 and the old website was with the version 7.3.4.

New Post
11/29/2018 2:15 PM

My workaround: I updated the “ModuleActions.js” file under “<rootdnn>\admin\Menus\ModuleActions folder”

Line 213: I added “.replace('http://','https://')” to the “action.Url”.

New updated line:

“htmlString += "<a href=\"" + action.Url.replace('http://','https://') + "\"" + (action.NewWindow ? " target=\"_blank\"" : "") + "><img src=\"" + action.Icon + "\" alt=\"" + action.Title + "\"><span>" + action.Title + "</span></a>";”

I don’t like to change the Core but this solution solved my problem with DNN Modal popups.

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...SSL website under F5 with VIPSSL website under F5 with VIP

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out