New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...HotFix "critical error" with HTML moduleHotFix "critical error" with HTML module
New Post
6/26/2017 8:51 PM


I was able to get the hotfix / patch installed and working on 3 DNN installations as instructed. However one patch didn't work out.

After the patch and recycling the app pool, attempting to edit an HTML module throws a "critical error" and won't open. There is a rather long event in the log, but the header contains the following (I've hidden the PublicKeyToken):

DotNetNuke.Services.Exceptions.PageLoadException: Exception has been thrown by the target of an invocation. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeInitializationException: The type initializer for 'Telerik.Web.UI.Common.HmacService' threw an exception. ---> System.Security.SecurityException: Request for ConfigurationPermission failed while attempting to access configuration section 'system.web/machineKey'. To allow all callers to access the data for this section, set section attribute 'requirePermission' equal 'false' in the configuration file where this section is declared. ---> System.Security.SecurityException: Request for the permission of type 'System.Configuration.ConfigurationPermission, System.Configuration, Version=, Culture=neutral, PublicKeyToken=################' failed.

Two other installations with almost identical configurations patched without issue (same DNN version 7.4.2 / skin / theme / modules / web hosting provider / etc.).

Thanks for any help offered.

New Post
6/29/2017 1:40 PM
Just a follow-up. I sent a support request to the DNN support / security email address a week ago and still no response. I'm getting more than a little stressed about if I'm going to be able to patch this site or not, and it's a big site. Does anyone know if there is any other way to contact DNN if I'm using DNN Community editions of the platform? Especially as this concerns a critical security issue that appears to affect over a decade of DNN versions? Thanks for any help offered.
New Post
7/2/2017 12:52 PM

I gave the hotfix another try this morning and got the same results -- "a critical error has occurred"  when attempting to edit an HTML module (which I assume has to do with the telerik components.) I have restored the site yet again from a backup.

Please DNN folks! I have tried repeatedly to contact your support staff with zero success.

The following was offered in the original email notice dated 6/23/2017 from DNN (and no, I'm not an Evoq customer, so I've used the [email protected] email address):

"Please do not wait to protect your site. It will only take a few minutes to install the patch. Our Customer Support Team is also available to address any questions that you may have."

"Evoq customers may create a support ticket to ask additional questions. Other DNN users may send an email to [email protected]"

Please. Some response. Any response...

New Post
7/2/2017 2:28 PM

I've done some more digging and there is a difference with my other sites that installed the hotfix -- they are running in Full Trust, whereas this site is running in Medium Trust. I changed the hosting space to Full Trust (both in the web.config file and via the hosting space Plesk ASP.NET settings) the site won't start and I get a server side configuration error. I have restored the web.config file from a backup and reset ASP.NET back to Medium Trust and the site is running again.

Before I really start trying to get the hosting space running in Full Trust can someone at DNN at least confirm that the Hotfix patch does require Full Trust to be installed?


New Post
7/3/2017 9:50 AM

FYI, I'm getting the same thing. Three installations just fine, but the fourth getting your exact same error message. I did a compare of the two config files, one that worked and the one that gets the error message. I'm finding differences, including missing this line: Telerik.AsyncUpload.ConfigurationEncryptionKey

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...HotFix "critical error" with HTML moduleHotFix "critical error" with HTML module

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out