New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeGetting StartedGetting StartedInstalling DNN ...Installing DNN ... New Install == 4049.0.1.142 New Install == 404
New Post
2/1/2017 6:21 PM
Wiped the folder, un-zipped the installer again. Deleted the DB from SQL and ran the installer.

This time I chose blank website.

Same result as when choosing default website. All links result in 404. Logout==404.
Check Message==404
Check Notifications==404
Click "SuperUser"== 404

When hitting home, I can see the blank content is full width and after a second the left edge slides in but nothing shows up in the blank space.

I even went so far as to disable ABP in the browser to see if that was interfering but it made no difference either.

Is 9.0.1 stable? Should I wipe it and try an older version of DNN?

This is running on Win 2k8R2 x64 on a Dell PowerEdge along side MSSQL 2008 x64.
New Post
2/1/2017 7:20 PM
Ok, I grabbed the installer. Again, wiped the folder, deleted the DB.

And :( Seriously, it doesn't work either. I had to fix a view that was throwing a conversion error. Man.

After running around that a while and getting the same 404s, I took a look at the web.config. It appears its missing a directive for the modules.

Under the block, its simply got a block. After I updated it so it would run all managed requests, DNN 8 now answers the URLs.

Again, wiped folder and DB and installed DNN 9.0.1. I made the same update to its web.config and voila! I have a top edit bar and clicking on the Notifications, Messages, and profile links no longer 404.

Don't know if it all works, but at least the fundamental ones do and the edit bar are now there. So thats progress anyway.
New Post
2/2/2017 10:26 AM
do not try blank website, please use default site template.
and in your IIS website settings, please make sure that .aspx is default document.

Cheers from Germany,
Sebastian Leupold

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
New Post
2/2/2017 3:28 PM
Thank you.

The default documents (global and this site inherits them) are:

The .ASP is there because I will eventually be running some ASP content there.
default.aspx is there for .NET site(s)
index.html is there for non-compiled content.

I had already tried blank site as well. No difference.

I believe the issue is because modules were not set to run in managed mode for all requests. I added the runAllManagedModulesForAllRequests in the web.config and it seems to respond correctly now.

HomeHomeGetting StartedGetting StartedInstalling DNN ...Installing DNN ... New Install == 4049.0.1.142 New Install == 404

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out