Learn More





New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Azure - no host menuAzure - no host menu
New Post
5/27/2015 10:00 PM

I've just completed DNN setup from the Azure market place and have logged in as a super user.

However I cannot see the host menu.

If I put the address in the address bar it says :

Access Denied

You do not have access to view this page within the website.



New Post
6/2/2015 3:07 PM
I have asked our Azure team to reply to your issue

Ken Grierson
DotNetNuke Corporation
Test Lead
New Post
6/2/2015 9:55 PM
Dan, there shouldn't be any difference with running the install in the Azure environment.

If the site is running OK and didn't show any install errors, is there anything else you did after the installation? You don't show what URL you're trying to access in your screenshot - this would be helpful.

The message you see is indicative of a lower-access user trying to access secured pages. Is it possible that your super user account was changed from being a super user, or anything like that?
New Post
3/6/2016 5:54 AM
I have the same issue, on a vanilla-site deployed directly from the Azure control panel, and with no change at all to configuration options (not even a skin change - through I later tried that).

Assuming I did something wrong myself, I delete the site and redeployed from the beginning using a new name for the resources. The result was the same. There is no Host menu when deploying to Azure.

The issue is not new. I attempted to deploy a test-site in November last year, and had the same issue, though at the time I did not completely understand what was goin on (I simply couldn't locate the SMTP settings). Back then I gave up and used another CMS. This time I'd like the opportunity to actually use DNN. And I am using a different Azure subscription this time, so I am pretty sure the issue is not directly related to the Region/Datacenter/Account used in Azure.

Let's stop assuming users are doing something wrong when installing, and realize that there is a potential issue with either DNN or with the current deployment scripts used in Azure. The issue is reproducable, and occurs even when no settings, skins or changes have been applied to the site. The symptom is simple: The Host menu item is absent.

The site only has a single user account, which is the Host account created during deployment. Perhaps the new Host account created during deployment has wrong data or insufficient rights?

In any case: Please look into this issue. A DNN portal without the Host configuration option is sort of like a hamburger without the beef... it's eatable, but something important is missing!
New Post
3/7/2016 4:42 PM

Hi Jesper, I'm sorry to hear you are having trouble.

I have just tried a default installation using the default parameters (BTW, I have seen that the Azure portal is using internally the DNN 7.4.0 when deploying the resource template instead of the latest version available), but got the host menu as shown below:

I think the issue can come from the installation taking longer than expected and something hitting the site while the installation is still in progress, causing an error when creating the resources:

1) Did you need to click on the "Retry" button during the installation? Did you detect something on the process or was all smooth?

2) Are you installing the English website template or another language?

3) Which datacenter location did you use? Were all the resources under the same location (dbserver, webfarm)?

4) I have checked that Basic tier for the database is not suitable and causes lot of issues during the install, but you mentioned that you left all the default parameters so S0 was the database size. Is this correct?

5) Can you provide more information on errors shown on the Event viewer or in /Portals/_default/Logs folder?

I would like to help you on this, more if we can solve a possible bug or template issue that can affect more community members.


David Rodriguez

David Rodriguez
DNN Cloud Team Lead Engineer | Microsoft Azure MVP | Microsoft Azure Insider / Advisor

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Azure - no host menuAzure - no host menu

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  

What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out