Products

Solutions

Learn More

Partners

Community

Blog

About

New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Language and In...Language and In...Change language for one user, using resourcefilesChange language for one user, using resourcefiles
Previous
 
Next
New Post
8/28/2014 8:27 AM
 
there is no need to enable content localization or providing a language selector in the skin.
It is just easier for testing, whether the language doesn't get switched for the user or the resource strings are not used properly in your module.

Cheers from Germany,
Sebastian Leupold

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
 
New Post
8/28/2014 9:01 AM
 

That's a relief.

I hve checked the following:

If I change the roles for this user, the mail, that is automatically sent, is in English. So the language for this user is correctly set to English.

The label is filled using Localization.GetString. It is filled correctly in Dutch. If I change the site language to English the label is filled in English. So that seems to working properly as well.

But if I set the site language to Dutch and the user language to English, the label is still in Dutch.


I hope this helps in solving my problem.

 
New Post
8/28/2014 9:06 AM
 
DNN uses just one language for both, UI and content (you may enable separation in Admin > Languages), i.e. you need to set current language to English for this user.
If you are using AdvancedControlPanel from www.oliverhine.com, you may configure UI language inside the control panel (if this user has access to it).

Cheers from Germany,
Sebastian Leupold

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
 
New Post
8/28/2014 9:27 AM
 
I'm sorry. I don't completely understand what you are saying.

I have set the Preferred Locale for this user to English.

 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Language and In...Language and In...Change language for one user, using resourcefilesChange language for one user, using resourcefiles


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  

What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out