Products

Solutions

Resources

Partners

Community

Blog

About

New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsRepositoryRepositoryUploading Large Files To The RepositoryUploading Large Files To The Repository
Previous
 
Next
New Post
9/12/2007 11:41 PM
 

Yes the default of 110 applies. 18000 is 5 hours if my math is correct which is a little long but then it looks like you've bumped the maxRequestLength up to close to a gigabyte. If you've got files that big then 18000 could be a decent time. Basically you want to set those values a low as you safely can as they do affect the website performance. I can't remember exactly what's affected but that's what I was told back I was asking the same questions on the old ASP.NET forum.

 
New Post
11/16/2007 6:39 AM
 

Would appreciate any update on this thanks.

I've also discovered that it looks like an upload is done and THEN a check if text is entered into the Description field is done. If this fails it reports an error and, then when corrected, requires that the file be uploaded again (i.e. another long wait). Also the file is uploaded and THEN the file type is checked (again wasted time and bandwidth).

Am running Repository 03.01.13 on DNN 4.4.1. web.config:

<httpRuntime
useFullyQualifiedRedirectUrl="true"
maxRequestLength="1024000"
requestLengthDiskThreshold="1024000"
executionTimeout="18000" />

Have uploaded a 14.5Mb file OK, but it times out on a 35Mb one.

 
New Post
11/16/2007 10:36 PM
 

Further info: the same behaviour happens when I use File Manager to upload to the site. FTP is fine with any sized files tested thus far. Any ideas please? I really need to be able to upload 20-40Mb files to the repository.

 
New Post
11/27/2007 7:48 PM
 

Were you able to find a resolution to this?  My site I'm working on is dependant on the ability for user to upload files up to 50mb.  I've upped the values in web.config to no avail.

 
New Post
11/27/2007 8:58 PM
 

I actually found the answer a few minutes after posting this.  I had copied the setting from the first page.  I then read the microsoft page referenced in the first post and realized that the requestLengthDiskThreshold probably should not be set so high.  Using these settings, I was able to upload a 50MB file with no issues.

<httpRuntime useFullyQualifiedRedirectUrl="true" executionTimeout="1000" maxRequestLength="50192" requestLengthDiskThreshold="8192" />

 

 
Previous
 
Next
HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsRepositoryRepositoryUploading Large Files To The RepositoryUploading Large Files To The Repository


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out