Products

Solutions

Resources

Partners

Community

Blog

About

New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsReportsReportsColumn headers always enabledColumn headers always enabled
Previous
 
Next
New Post
4/28/2008 6:54 PM
 

Strange, but even when I change the value on the TabModuleSettings table, it does the same: it shows the header!? I can't wait for new version :)

Did anyone try to update the TabModuleSettings and it was working? And yes, all reports created in previus version are OK and they have the same setting as the one I updated manualy!?

 
New Post
5/5/2008 11:58 AM
 

I have developed a CSS-based workaround that will hide the headers from users, while still rendering them to the HTML. Unless you absolutely require that the headers not be rendered, please use this workaround. If, for some reason, this workaround is unsuitable, please contact me at: andrew DOT nurse AT dotnetnuke DOT com and I will attempt to provide another workaround.

I do apologise for any inconvenience caused by this. Please note that the bug has been fixed in the next version, so this is only a temporary workaround and will no longer be necessary in version 5.1

The CSS workaround will be posted as a reply to this post in the next few minutes. I have pinned this topic so that anyone else with the problem can locate this workaround.


Andrew Nurse
DotNetNuke Core Team Member and Reports Module Project Lead
Microsoft Certified Professional Developer

 
New Post
5/5/2008 12:09 PM
 

Temporary CSS-based workaround:

1. In the settings page for the Reports Module instances you wish to hide the headers for, append "HideHeaders" to the "CSS Class" setting for the Grid Visualizer (you may have as many space-separated CSS classes here as you want, order does not matter).

2. Open the file ~/Portals/[PortalID]/portal.css for the portal(s) you wish to hide the headers for, and add the BOLDED CSS (non-bolded lines should already exist and are shown for context)

/* ================================
    CSS STYLES FOR DotNetNuke
   ================================
*/  

/* TEMPORARY WORKAROUND FOR Reports Module BUG */
table.HideHeaders tr.DNN_Reports_Grid_Header {
    display:none;
}


/* PAGE BACKGROUND */
/* background color for the header at the top of the page  */
.HeadBg {
}

This can also be done using the Stylesheet editor on the Admin > Site Settings menu.

Save changes, and the headers should disappear. This will only affect those modules with the CSS Class attribute set to "HideHeaders". If this name conflicts with another CSS Class in your portal, change it in both the Module Settings and CSS File. Since this workaround does not add any additional code, and only affects Reports Modules with a certain CSS Class, it should be safe for use in production, but ensure you back up your CSS files BEFORE changing them, just in case.

NOTE: The Headers will still be present in the HTML file.

 


Andrew Nurse
DotNetNuke Core Team Member and Reports Module Project Lead
Microsoft Certified Professional Developer

 
New Post
6/4/2009 5:12 AM
 

hi, thanks for the workaround.

however the headers will appear again if theres paging enabled (i.e. when clicking on other pages, and back to page 1 of the grid).

any solutions for this?

 

thanks!

 
New Post
8/24/2009 8:01 PM
 

Andrew Nurse wrote

I do apologise for any inconvenience caused by this. Please note that the bug has been fixed in the next version, so this is only a temporary workaround and will no longer be necessary in version 5.1

Has this been fixed in the code yet?  I'm using DNN 05.01.00 (773) and Reports Module 5.1.

When I create a report using Grid Visualizer, and uncheck "Show Header," the header continues to display, and when I reload the settings for the module, "Show Header" is still checked.  This sounds like the same bug being discussed in this thread, so it would appear that it has not yet been corrected.

 
Previous
 
Next
HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsReportsReportsColumn headers always enabledColumn headers always enabled


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out