New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsLinksLinksResource can not be found.Resource can not be found.
New Post
4/30/2009 12:50 PM

I am getting this error on every portal of my DNN installation.  Weather it is an external link,  link to a page on the site, or a file.  This modual did work up till two weeks ago.  And I am not 100% on every thing that was changed since then.  My question is has any one else ran into this error, and if any one know if its and issue witht he DNN installation or my web server.  Unfortuanalty I am using a hosting company, and I am not sure if they changed any thing,  or what to tell them to change that they can understand.  Unfortuanatly this company decided it did not need tech savy people to work the help desk there.  I mean no one know what IIS is  there,  and when you try to tell them its the thing you support they argue with you.  But back to my question,  any one got any ideas where to start?


I tried to have my hosting company allow headers but it did not work,  or they did not do it right.


any help would be greatly appreciated, as my application is now live and customers are getting worried. 



Server Error in '/' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /LinkClick.aspx


Here is the Settings of the link clicked.


New Post
5/1/2009 6:32 AM

I mean as you can see the handlers are set appropiatly here, according to what the web config looks like from fresh install.


Any one got any ideas?  Clients are really getting spupicious of reliability of DNN,  and I know it has to be just some setting is off,  just not sure what to look for.




      <!-- This is for CAPTCHA support -->
      <add verb="*" path="*.captcha.aspx" type="DotNetNuke.UI.WebControls.CaptchaHandler, DotNetNuke" />
      <!-- This is for Serving files, secure, insecure, from database -->
      <add verb="*" path="LinkClick.aspx" type="DotNetNuke.Services.FileSystem.FileServerHandler, DotNetNuke" />
      <!-- This adds syndication support -->
      <add verb="*" path="RSS.aspx" type="DotNetNuke.Services.Syndication.RssHandler, DotNetNuke" />
      <!-- This adds legacy support for the Logoff page -->
      <add verb="*" path="Logoff.aspx" type="DotNetNuke.Services.Authentication.LogOffHandler, DotNetNuke" />
      <!-- ASP.NET AJAX support -->
      <remove verb="*" path="*.asmx" />
      <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
      <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
      <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />
      <add verb="POST,GET" path="ajaxpro/*.ashx" type="AjaxPro.AjaxHandlerFactory, AjaxPro.2" />

New Post
5/5/2009 12:17 PM

Hi, Luke-
I can't say for sure from the info you've posted but one possibility is that your fileid values have been reassigned.  This can happen in older versions of DNN (before DNN 4.9.2).
See some info on a possible cause here:

  Lost and Corrupted LinkClick links in DNN Modules
To know for certain, you'll want to compare the fileid of an affected LinkClick link to the value of the fileid in your FILES table.   If the LickClick fileid does not appear in your FILES table then this is your issue.


New Post
5/8/2009 3:27 AM

So i hate it when you stumble upon a closed form posting with the exact issue you were facing and no one ever update it with the actuall issue at hand, so any time i post something I try and put a resolution if none was provided.

Okay so what I have found this issue to stem from:

my applications were running in integrated mode, not classic mode.  I am not sure why but my hosting company decided to switch these settings on me some how and this cause this issue. 

I hope this helps some one in the future.





New Post
3/7/2012 6:53 PM

Thanks heaps for posting that... I was scratching my brain as to why this just stopped working all of a sudden.

I checked the .NET settings and it was set to 2.0 Integrated Pipeline. Changed it to simply 2.0 and solved the problem.

HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsLinksLinksResource can not be found.Resource can not be found.

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out