Products

Solutions

Learn More

Partners

Community

Blog

About

New Community Website

Ordinarily, you'd be at the right spot, but we've recently launched a brand new community website... For the community, by the community.

Yay... Take Me to the Community!

Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Member search by filter does not workMember search by filter does not work
Previous
 
Next
New Post
10/15/2016 10:01 AM
 
I ended up replacing the getuseradvanced search with the original dnn sproc and that fixed the problem I don't have access yet to sql profiler, so sorry Sebastian I would have otherwise been able to provide you with some insight into what was going wrong.
 
New Post
10/15/2016 11:40 AM
 
I just checked at one of my DNN 7.4.2 filtering by Country and had no issues.
Which datatype does your usertype property have?

Cheers from Germany,
Sebastian Leupold

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
 
New Post
10/15/2016 12:38 PM
 
Hi Sebastian

The filtering itself works ok. It's the member search that has problems. If the filter type is other than none, the search does not work unless you explicitly search for the full name. The partial search does not work nor does auto complete. I am filtering on a custom profile property type of text.

 
New Post
10/15/2016 12:58 PM
 
I just checked the stored procedure on a custom (numeric) property and it works as expected - it automatically checks for any value, which STARTS with the given string, I just changed that to limit it to strings, which match the string (you may use '%' to search for values starting with the value).

Cheers from Germany,
Sebastian Leupold

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
 
New Post
10/15/2016 1:35 PM
 
It could be my installation/skin etc - it's 8 years old and a bit messy :) Getting ready for a clean install of 8. Thanks for looking into this.
 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Member search by filter does not workMember search by filter does not work


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  

What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out