Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...DNN 6 to DNN 8.0.4  API 404 (Not found)DNN 6 to DNN 8.0.4 API 404 (Not found)
Previous
 
Next
New Post
5/19/2017 9:19 PM
 

Hello,

I hope I am in the right place. We have quite a few clients in which we had upgraded them from DNN 6 to DNN 8. However we are now having issues with a few of them being unable to add new/existing modules or edit the pages. It results in https://website.local/folder/DesktopModules/internalservices/API/controlbar/ToggleUserMode 404 (Not Found) and refreshes the page.

From googling, we had hoped that changing the controlpanel from ControlBar to Ribbonbar would workaround the issue as we had found it had fixed someone else's issue previously but unfortunately when it comes to actually changing the page it brings up the same error.

We have also tried <modules runAllManagedModulesForAllRequests="true"> it only hid the error. 

The event log does not provide any information.

Any assistance on where I can look next is greatly appreciated.

 
New Post
5/23/2017 7:10 PM
 
When you did the upgrade from DNN 6 to DNN 8, did you follow the suggested upgrade path (see the Wiki)?

If not (or you aren't sure), it might make sense to take one of those DNN 6 installs (assuming that you have a backup), install it somewhere and try the upgrade using the suggested path.

You could also go through the logs on an upgraded site an check for errors that might have been missed during the upgrade.



Joe Craig
Patapsco Research Group, Ellicott City, MD
DotNetNuke Development and Services (http://patapscorg.com)
 
New Post
5/23/2017 11:29 PM
 

We did do the suggested upgrade path and we do have backups.

I did check the files on the site in the mean time. Well, actually I replaced all but web.config from an fresh/blank upgrade. No changes.

Will go through restore and re-upgrade tomorrow, it is possible I missed something, I'll provide an update with the results and any install logs errors I find.

 

 
New Post
5/25/2017 5:53 PM
 

Looks like I had caching issues.

Just for the benefit of the doubt I retried <modules runAllManagedModulesForAllRequests="true"> and cleared the cache and restarted the application. 

That was the fix.

 

 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...DNN 6 to DNN 8.0.4  API 404 (Not found)DNN 6 to DNN 8.0.4 API 404 (Not found)


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out