Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Text modules not updating and blog link redirects to current pageText modules not updating and blog link redirects to current page
Previous
 
Next
New Post
5/16/2017 2:19 PM
 

Noticed a few days ago that all of our DNN sites across multiple servers are not allowing us to update content in the text modules, plus when click on links to blog posts (Sunblog) for example it just refreshes the main blog page instead of going into the post.  The sites are running on stacks that have installs of DNN 6, 7 and 8.   There is a central DB server, which seems to be running fine and it has been rebooted. The web servers have been rebooted as well.  At one point we updated some TLS settings in the registry but we have reverted back on those, and rebooted the server after.

We are having this issue with sites that are SSL and Non-SSL.  Also with www and non-www set as primary domains.  We always have a number of errors in both event viewer on web servers its hard to tell if anything new related to this issue. 

Details:

Environment
==========

- Two 2008R2 web servers
- One 2008R2 MSSQL 2008

History: 
====== 

- The issue appeared to start with a change to TLS that was made Friday evening to deal with PCI compliance, but may be unrelated. During this update the registry keys specified in https://technet.microsoft.com/en-us/library/dn786418(v=ws.11).aspx#BKMK_SchannelTR_TLS10 were added to the registry in both web servers (but not the database) in order to set:
TLS 1.0 off 
TLS 1.1 off 
TLS 1.2 on

Specifically:
TLS 1.0 
Client 
Enabled = 0 
Server 
Enabled = 0 
TLS 1.1 
Client 
Enabled = 0 
Server 
Enabled = 0 

The TLS 1.2 was already there and on, so he did not touch it.

After server reboot, the server didn't come back up and was unreachable via RDP. We got back in via remote KVM and rolled back the TLS changes.

Current Symptoms 
============ 
- Unable to update text modules 
- Blog links don't work 
- When logged in, the above does work 
- Effects SSL and non SSL sites 
- Effects sites on Web1 and Web2 
- Effects www and non-www primary

Troubleshooting steps taken 
====================== 
- All TLS changes have been reverted (not able to confirm this has been effective) 
- Web1, Web2 and DB have been restarted 
- Change primary domain from www to non www version.

 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Text modules not updating and blog link redirects to current pageText modules not updating and blog link redirects to current page


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out