Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...500.19 Error 500.19 Error
Previous
 
Next
New Post
4/30/2017 3:16 AM
 

When running up DNN on Windows 10 / IIS 10 I get this error below.  I can find the section to edit in the applicationHost.config file but of course can't save it even with running Notepad as an administrator.

The error seems to imply that the handlers section is locked at the global level and no config file below this level may override it.  This is daft ... DNN won't work with the <handlers> section disabled and with no way to override.

Read over this material: https://www.iis.net/learn/get-started/planning-for-security/how-to-use-locking-in-iis-configuration but it fails at one point -- no way to save the file after editing.

This is either a red herring or one heck of a stonewall by Microsoft to prevent people from harming their computers.  The file needs to be edited.  How is this done?

Here is the section in the applicationHost.config:

        <sectionGroup name="system.webServer">

            <section name="asp" overrideModeDefault="Deny" />

            <section name="caching" overrideModeDefault="Allow" />

            <section name="cgi" overrideModeDefault="Deny" />

            <section name="defaultDocument" overrideModeDefault="Allow" />

            <section name="directoryBrowse" overrideModeDefault="Allow" />

            <section name="fastCgi" allowDefinition="AppHostOnly" overrideModeDefault="Deny" />

            <section name="globalModules" allowDefinition="AppHostOnly" overrideModeDefault="Deny" />

            <section name="handlers" overrideModeDefault="Deny" /> <-- need to set to 'allow' or put it in an unlocked section at the end of the file.

            <section name="httpCompression" overrideModeDefault="Allow" />

            <section name="httpErrors" overrideModeDefault="Allow" />

            <section name="httpLogging" overrideModeDefault="Deny" />

HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information:

Module    IIS Web Core
Notification    BeginRequest
Handler    Not yet determined
Error Code    0x80070021
Config Error    This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File    \\?\D:\DNNSites\DurthalerTechSvcs\httpdocs\web.config
Requested URL    http://localhost:80/dts.local.com
Physical Path    D:\DNNSites\DurthalerTechSvcs\httpdocs
Logon Method    Not yet determined
Logon User    Not yet determined

Config Source:

   92:     </modules>
   93:     <handlers>
   94:       <remove name="WebServiceHandlerFactory-Integrated" />

More Information:

This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.

View more information »

 
New Post
4/30/2017 11:46 AM
 

This will sound bizarre ... :) I can edit the file on my other laptop, which has McAfee installed.  This overrides Windows 'Defender', which comes with Windows 10.  Just simply open the file with Notepad, running Notepad as Admin first.  On my new machine, I can do this with the Hosts file to set up DNS for DNN.

My other machine is used for educational / non profit stuff where my MSDN subscription restrictions come into play.  same environment except for not having McAfee installed on my newer 'for profit' machine.

Will install McAfee later intended to do that soon enough anyway.  Let's play my hunch out that McAfee will override Windows 'Defender' and then, mysteriously, I'll be able to edit the file.

That may be it.

 
New Post
5/1/2017 11:34 PM
Accepted Answer 

The problem is IIS was not fully set up on my new machine.

The settings that are in IIS on my old machine match those that were in my new machine.  So there's no reason it should not have worked.

Apparently Windows 10 Pro assumes an end user isn't doing any dev work by default.  And if one doesn't specifically set up IIS in the latest and greatest update of Windows 10 you're just locked out and get goofy errors.

In Windows Features / IIS I had to specifically select ASP.Net 3.5 and ASP.Net 4.7, which in turn selected the correct defaults.  Then applying the changes got me to the next steps to clean up to get the site working in local host.

Just in case someone else runs into the same trouble.

 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...500.19 Error 500.19 Error


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out