Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Enabling browser language detectionEnabling browser language detection
Previous
 
Next
New Post
3/17/2017 10:01 AM
 
Hello,

I want to use the feature for detection but I can't make it work. Here's what I've done until now:
1. I'm using DNN 8.0.4 (clean installation) and I have 4 language. The content is fully localized and all pages are published in all languages.
2. I went to admin > Languages and enabled the the browser language detection.
3. I changed the language of my browser (In Chrome I went to settings > advanced settings>Languages and I set to display Google Chrome in German) and run the site. The site displays in the default language and not in the german language as I would expect.
4. After reading around the forums and blogs, I decided to change my aliases because I thought perhaps I hadn't set them correctly. First, I added the language definition in the portal aliases. Nothing. Then I made primary one alias for each language. Nothing. Then I stripped the language definition and the aliases for each language and kept only one alias, the main one. Still nothing.

I'm definitely doing something wrong, could someone explain the process step by step to make the feature work?

Thank you in advance.
 
New Post
3/18/2017 10:44 AM
 
you need a primary site alias for each language.
Besides, you should not be logged in, as the preferred language in your profile overrides DNN language selection.
You should also clear site cookies in your browser, which might keep language selection between sessions.

Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
 
New Post
3/20/2017 7:54 AM
 
Hello Sebastian,

Here is a screenshot of how I set up the aliases:
The screenshot is uploaded in google drive
Each language has a primary alias.
I open chrome (I am not logged in and I have changed the settings as I described in the first post so that the browser is in German), I have cleared everything (history, cookies etc) and I browse the site.
The site is displayed in the default language. What am I missing??
 
New Post
3/24/2017 7:37 AM
 
any ideas on this one? I'm still stuck..
 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Enabling browser language detectionEnabling browser language detection


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out