Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsDocumentsDocumentsError when exporting from very old version to newer versionError when exporting from very old version to newer version
Previous
 
Next
New Post
3/2/2017 7:50 PM
 
I have a very old instance of DNN with Documents module version 3.01.06. This DNN instance holds hundreds of documents. The documents modules from this instance need to be moved to another, more updated, instance of DNN with Documents module version 6.01.00. However, when I export the content from a module in the old DNN instance and import to the new DNN instance, I get an error.

Is there a way to move the content from one DNN instance to another if there is such a large version difference?
 
New Post
3/3/2017 2:19 PM
 
Hello,

If you have extensive content which you want to keep, instead of creating a new DNN instance, why don't you go with upgrade? That way you will keep your content as is. (backup before upgrading and keep in mind you will need to upgrade skins and modules as well in order for everything to work)
Also it would be good to know what version is the old site and what version is the new and what kind of error you get.
 
New Post
3/3/2017 4:30 PM
 
It's likely that the "new" version of the documents module includes some pieces not in the old version, so the import fails.

One way of dealing with this is to compare the structure of the exported file from the old module to an export file using the new module.

You may be able to discern the differences and then be able to edit the old file -- it's and XML file -- so that it will work with the new module.



Joe Craig
Patapsco Research Group, Ellicott City, MD
DotNetNuke Development and Services (http://patapscorg.com)
 
New Post
3/18/2017 3:27 PM
 
if using same SQL server, it might be easier transferring data using SQL.
However, this requires some basic understanding of SQL and has some challenges.
did you try uninstalling version 6 from the target site, installing version 3, importing the data and upgrading the module?

Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
 
Previous
 
Next
HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsDocumentsDocumentsError when exporting from very old version to newer versionError when exporting from very old version to newer version


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out