Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Language and In...Language and In...Problem with NavigateURLProblem with NavigateURL
Previous
 
Next
New Post
3/3/2016 2:28 PM
 

Hi, I have some problem with a multi-language site.

I enable "Allow Content Localization" on host, and add some languages (I follow http://www.dnnsoftware.com/community-blog/cid/155042/content-localization-walkthrough to da that).

My problem is with redirection, using NavigateURL, for example:

In the url: "http://localhost/dnn_07.04.02_master/es-es" if I use: "DotNetNuke.Common.Globals.NavigateURL(tabId)" it return "http://localhost/dnn_07.04.02_master/es-es/en-us/report.aspx", it include the default language "en-US", not the actual language "es-ES"

I have this site alias:


Do you have any idea which is the problem?


Thanks,

Pablo

 
New Post
3/3/2016 8:19 PM
 
I don't think you should have those Aliases in there?

Chris Hammond
Former DNN Corp Employee, MVP, Core Team Member, Trustee
Christoc.com Software Solutions DotNetNuke Module Development, Upgrades and consulting.
dnnCHAT.com a chat room for DotNetNuke discussions
 
New Post
3/3/2016 8:33 PM
 

I create that alias because I follow the instruction from"http://www.dnnsoftware.com/community-blog/cid/155042/content-localization-walkthrough"

Now I remove all aliases but I have the same result.

 
New Post
3/3/2016 8:45 PM
 
Chris Hammond wrote:
I don't think you should have those Aliases in there?

Chris is not right. Your Alias list is correct.

 

There were, however, issues reported with sites in subfolders. I would try to install DNN in the root of the website.


Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
 
New Post
3/4/2016 9:15 AM
 

I restore all the site aliases and move the site but I continue with the same problem.

Any other idea?

 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Language and In...Language and In...Problem with NavigateURLProblem with NavigateURL


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  


Copyright 2017 by DNN Corp Terms of Use Privacy
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out