Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...HELP just upgraded to version 7.4.2 and my Host panel does not work anymoreHELP just upgraded to version 7.4.2 and my Host panel does not work anymore
Previous
 
Next
New Post
2/17/2016 4:32 AM
 

I have been having problems with SQL injection attacks and XSS attacks lately. For this reason I decided to upgrade my installation to the first version that does not seem to have this type of vulnerability.

The upgrade process was fine. No red warning signs, everything went pretty smoothly.

I looked around my websites and funcionality looked normal and so did the general appearance.

This morning I tried to add a module to a page but realised I just could not do it. I already had problems with the controlbar when I was on version 7.2. I tried a couple of things suggested by Sebastian Leupold but could not fix it so in the end I simply decided to stick to the old ribbonbar which was working fine until this morning.

This morning every trime I tried to add an HTML module to my page DNN ended up adding a banner module instead.

I tried various times trying to change the pane, the module and so on but it only seemed to be able to add a banner module for some obscure reason.

I therefore tried to use change the type of control and selected the controlbar but had the same problem I had before. After selecting Add module the process of finding the modules seemed to go on forever. I went back to the ribbonbar but the issue was still there. Tried emptying the cache to no avail. Tried restarting applicatio, still no good.

I finally tried to select ICONBAR as my control bar and that's when the real problems started. 

At this point nothing works anymore. Each time I try to login on the main website I get a 

Server Error in '/' Application.

I do manage to log into my other websites but when I click on the Host button to try and change my settings the page does not load and it simply stays on the page it was on before.

Is there anything I can do to fix this apart from restoring back to the previous version???

Please anyone

 
New Post
2/17/2016 6:16 AM
 

After restoring yesterday night's database I still have a problem on my main host site (website 0 so to speak).

Only on this website, each and every time I try to log in I get the new Welcome to your website window (by the way, how do I get rid of that?) and another smaller window keeps popping up with 

Server Error in '/' Application.

I tried turning custom errors off to try to understand why this is happening but no matter what I do, no detailed error shows and the thing just keeps on repeating itself.

Ok now, this is new. I tried hitting the Esc key a couple of times on page load and I got this other error message in the small popup window.

Server Error in '/Dotnetnuke' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /Dotnetnuke/Default.aspx

Since I managed to get my RIBBONBAR back I looked through the logs and I see this bunch of errors

2016-02-17 12:10:30,791 [websv08][Thread:10][WARN] DotNetNuke.Services.Localization.LocalizationProvider - Missing localization key. key:ControlTitle_.Text resFileRoot:/DesktopModules/HTML/App_LocalResources/HtmlModule threadCulture:en-US userlan:

2016-02-17 12:10:32,387 [websv08][Thread:27][TRACE] DotNetNuke.Web.Common.Internal.DotNetNukeHttpApplication - Dumping all Application Errors

2016-02-17 12:10:32,390 [websv08][Thread:27][FATAL] DotNetNuke.Web.Common.Internal.DotNetNukeHttpApplication - System.Web.HttpException (0x80004005): The file '/images/108604.aspx' does not exist.

   at System.Web.UI.Util.CheckVirtualFileExists(VirtualPath virtualPath)

   at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)

   at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)

   at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean throwIfNotFound)

   at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp)

   at System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)

   at System.Web.UI.PageHandlerFactory.GetHandler(HttpContext context, String requestType, String virtualPath, String path)

   at System.Web.HttpApplication.MaterializeHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

2016-02-17 12:10:32,393 [websv08][Thread:27][TRACE] DotNetNuke.Web.Common.Internal.DotNetNukeHttpApplication - End Dumping all Application Errors

I went back to the previous version I had DNN 7.3.2 but the problem installing the HTML module on a page seems to be still there. Bad thing is I don't have a copy of the files for the previous version to go back to. I only have a copy of the DNN database.

Can I go back with only the DB? Is there a way to solve the problem with the HTML module?

Still, every time I try to log in to a website I get the error window

Server Error in '/' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /Home/tabid/Login.aspx

I'm seriously thinking of trashing the whole thing altogether.

 

 
New Post
2/17/2016 8:11 PM
 
please check Site settings, especially special pages settings for your site.
are you using plain English version or a language pack?
did you unblock downloaded upgrade package prior to unzipping the files contained?

Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
 
New Post
2/18/2016 4:12 AM
 
Sebastian Leupold wrote:
please check Site settings, especially special pages settings for your site.
are you using plain English version or a language pack?
did you unblock downloaded upgrade package prior to unzipping the files contained?

Hello Sebastian, 

what do you mean by special pages settings?

I'm using more than one language pack. One website has 4 languages, another one has three, one is English only and a couple of others are Italian only.

I managed to eliminate the Welcome to your website page. I found the solution browsing the Forum. No idea why it continuously gave a page not found error but that's beyond the point. I'm almost sure the problem adding the module to my page (the only module that gets added for some obscure reason is the Banners module in the Admin category) has something to do with the skin I'm using.

I noticed the problem disappears whenever I use the Dark Knight skin to add the module so my workaround has been to preview my website with Dark Knight, add the module and then continue working with my regular skin. It's far from ideal but it works.

I have contacted the people I've purchased the skin from through the DNN store interface and I hope they have a solution.

What do I have to do to get rid of all the "missing resource" errors on my DNN application?

Thank you

Edoardo

 
New Post
2/20/2016 5:05 AM
 
I have contacted the guys who sold me the skin I'm using on my website and told them about my problem adding modules using their skin.
They asked me to create a temporary Host account to allow them to fix the problem but giving access to all my installation specific info sort of freaks me out.
I did do that in the past and now I have this problem with the phantom hackers attacking my website with cross side scripts and SQL injections.

Do you suggest I do this? Is this safe? Is there a way to do this safely?
 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...HELP just upgraded to version 7.4.2 and my Host panel does not work anymoreHELP just upgraded to version 7.4.2 and my Host panel does not work anymore


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  


Copyright 2017 by DNN Corp Terms of Use Privacy
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out