Learn More





Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...FriendURL rewrite issue (homepage)FriendURL rewrite issue (homepage)
New Post
6/15/2015 11:39 AM

Hello. I'm having difficulty with the Friendly rewrite system on the default.aspx.

If I disable friendly url's for the homepage (aka Page Settings -> Do Not ReWrite), it breaks all the modules on it (displaying red error boxes); so that isn't an option, nor should it be - we want friendly url's. We also want google analytics.

I am using google analytics for links, which requires the url to have certain query variables in the GET request. 
Unfortunately, DNN is removing them on default.aspx, and rewriting like so:

Which is incredibly frustrating, because there isn't a single page anywhere in any place on the entire internet let alone my website, that could ever possibly reside under that rewritten url. It's entirely pointless. It doesn't even do a page search, it just results in the homepage being shown.
Forgive me for not understanding the logic behind this rewrite rule, or whatever it is.

It works on all other pages. Not the homepage. And we need a resolution !

I have tried a catch all regex (    .*utm_source.*    ):

  • AUM_DoNotRedirectUrlRegex
    No effect
  • AUM_DoNotRewriteRegEx
    No effect
  • AUM_DoNotUseFriendlyUrlRegex
    No effect
  • AUM_IgnoreUrlRegex
    Works, but results in a null reference exception in 
  • AUM_KeepInQueryStringRegex
    Seriously, no effect?!?!?
  • AUM_ValidFriendlyUrlRegex
    again.... no effect.

Can anyone suggest a resolution for this problem? 
Do I need to write a custom Friendly URL provider, and somehow block the default DNN system from operating on the default.aspx page? 
Is there a web.config manipulation I could make in the Friendly URL regex to handle this requirement?
Any suggestions would be great, please and thank you!!

New Post
6/18/2015 12:54 PM
I ended up disabling friendly URL's for the home page of our site. Not something I wanted to do, but it's the only solution I can find within a timely manor.
That setting is under Page Settings(Do not rewrite).

Had to fix other issues that this caused, but, it's stable and working.
Not sure that this post will help others in the same situation, or if anyone will ever encounter said situation.
But wanted to follow up and mark it resolved.
New Post
6/18/2015 12:54 PM
 * double post *
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...FriendURL rewrite issue (homepage)FriendURL rewrite issue (homepage)

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
Try Evoq
For Free
Start Free Trial
a Demo
See Evoq Live
Need More Information?