Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsBlogBlogDNN Blog 6.1.1 - Problem with tag listDNN Blog 6.1.1 - Problem with tag list
Previous
 
Next
New Post
4/8/2015 9:30 PM
 

Hi,

I added a tag-list module on a blog page and it works (shows all the tags). When I click on a blog item within a blog list it opens the blog post but the tag-list crashes with the following error:

Error: Object reference not set to an instance of an object.


In: at DotNetNuke.Modules.Blog.Entities.Terms.TermInfo.PermaLink(TabInfo tab) at DotNetNuke.Modules.Blog.Entities.Terms.TermInfo.GetProperty(String strPropertyName, String strFormat, CultureInfo formatProvider, UserInfo AccessingUser, Scope AccessLevel, Boolean& PropertyNotFound) at DotNetNuke.Modules.Blog.Templating.BaseCustomTokenReplace.replacedTokenValue(String strObjectName, String strPropertyName, String strFormat) at DotNetNuke.Modules.Blog.Templating.BaseTokenReplace.ReplaceTokenMatch(Match m) at System.Text.RegularExpressions.RegexReplacement.Replace(MatchEvaluator evaluator, Regex regex, String input, Int32 count, Int32 startat) at System.Text.RegularExpressions.Regex.Replace(String input, MatchEvaluator evaluator) at DotNetNuke.Modules.Blog.Templating.GenericTokenReplace.ReplaceTokens(String strSourceText) at DotNetNuke.Modules.Blog.Templating.Template.ReplaceContents()

Error: Object reference not set to an instance of an object.

In: at DotNetNuke.Modules.Blog.Entities.Terms.TermInfo.PermaLink(TabInfo tab) at DotNetNuke.Modules.Blog.Entities.Terms.TermInfo.GetProperty(String strPropertyName, String strFormat, CultureInfo formatProvider, UserInfo AccessingUser, Scope AccessLevel, Boolean& PropertyNotFound) at DotNetNuke.Modules.Blog.Templating.BaseCustomTokenReplace.replacedTokenValue(String strObjectName, String strPropertyName, String strFormat) at DotNetNuke.Modules.Blog.Templating.BaseTokenReplace.ReplaceTokenMatch(Match m) at System.Text.RegularExpressions.RegexReplacement.Replace(MatchEvaluator evaluator, Regex regex, String input, Int32 count, Int32 startat) at System.Text.RegularExpressions.Regex.Replace(String input, MatchEvaluator evaluator) at DotNetNuke.Modules.Blog.Templating.GenericTokenReplace.ReplaceTokens(String strSourceText) at DotNetNuke.Modules.Blog.Templating.Template.ReplaceContents()


Any ideas?

Harald

 
New Post
7/13/2015 4:26 PM
 

Hi,

I am getting a very similar same error as Harald above on a clean install of Blog v6.1.2 on DNN Community edition  v7.3.4. The error is:

Error: Object reference not set to an instance of an object.

In: at DotNetNuke.Modules.Blog.Entities.Posts.PostInfo.PermaLink(TabInfo tab) at DotNetNuke.Modules.Blog.Entities.Posts.PostInfo.PermaLink(Int32 strParentTabID) at DotNetNuke.Modules.Blog.Entities.Posts.PostInfo.GetProperty(String strPropertyName, String strFormat, CultureInfo formatProvider, UserInfo AccessingUser, Scope AccessLevel, Boolean& PropertyNotFound) at DotNetNuke.Modules.Blog.Templating.BaseCustomTokenReplace.replacedTokenValue(String strObjectName, String strPropertyName, String strFormat) at DotNetNuke.Modules.Blog.Templating.BaseTokenReplace.ReplaceTokenMatch(Match m) at System.Text.RegularExpressions.RegexReplacement.Replace(MatchEvaluator evaluator, Regex regex, String input, Int32 count, Int32 startat) at System.Text.RegularExpressions.Regex.Replace(String input, MatchEvaluator evaluator, Int32 count, Int32 startat) at System.Text.RegularExpressions.Regex.Replace(String input, MatchEvaluator evaluator) at DotNetNuke.Modules.Blog.Templating.BaseTokenReplace.ReplaceTokens(String strSourceText) at DotNetNuke.Modules.Blog.Templating.GenericTokenReplace.ReplaceTokens(String strSourceText) at DotNetNuke.Modules.Blog.Templating.Template.ReplaceContents()

I get the error when, on the "Blog Settings" tab under Settings I changed the template dropdown from "default" to "Latest Posts". When I change back to "Default" it is fine. I have been looking into this but I am mystified by this. Any ideas?

Thanks!

Eoghano

 
New Post
5/29/2016 1:34 PM
 
This is being discussed on GitHub
https://github.com/DNN-Connect/DNN-Bl...

There is a fix involving re-compiling and replacing the dll.
I have also posted a script you can add to the header of the module to suppress the error messages when they appear.
That may suffice for you until the fix is released.
 
Previous
 
Next
HomeHomeDNN Open Source...DNN Open Source...Module ForumsModule ForumsBlogBlogDNN Blog 6.1.1 - Problem with tag listDNN Blog 6.1.1 - Problem with tag list


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  


Copyright 2017 by DNN Corp Terms of Use Privacy
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out