Learn More





Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Default DocumentDefault Document
New Post
2/27/2015 1:32 PM


 It looks like my DNN default.aspx page loads even if I have default document set to index.html in IIS7.5

What I am trying to achieve is to have a splash page (index.html) and then have a link to the DNN site from there.

Every time I go to it always goes to

In IIS 7.5 I have the index.html as the default document. 

I want to go to first

For some reason I cannot change this no matter what I do.

Any help would be appreciated.

I’m using DNN 7.03.04

Windows Server 2008 R2

New Post
3/4/2015 3:52 PM
Any request DNN processes ultimately goes to default.aspx -i havent tested it but i suspect that you can configure the url rewriter to ignore requests for index.html ( will help configure this)

Buy the new Professional DNN7: Open Source .NET CMS Platform book Amazon US
New Post
3/4/2015 6:21 PM
if you want to be index.html handled by IIS, please make sure in IIS configuration, it is listed above default.aspx.

Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group   European Network of DotNetNuke Professionals

Speed up your DNN Websites with TurboDNN
New Post
3/4/2015 6:51 PM

Thanks for the replies.  I think I am going to try with the URL rewriter.  

I triesdthe IIS 7 Default Document and it does not work.  I had index.html above it, below it.  I removed default.aspx all together and it still went to default.aspx.  It is like it ignores it and always launches the DNN default,.aspx[page.  I  started and stopped the IIS services, etc... and still no change.





New Post
3/5/2015 8:53 AM

Hi Everyone,

Thanks to the previous reply I am convinced it has something to do with URL redirecting.  

Every time I go to root website:  Ex. 

It automatically goes to default.aspx.

In IIS7 I have the default document set to index.html.    (Both files are in the root of the website)

After doing more research I discovered that the web.config totally overrides any IIS 7 setting and therefore totally ignores the default document feature in IIS.  Since the web.config has URL rewriting info I tghink this is the culprit.

Does anyone know how I can change this? 

I loaded the X3.DnnUrlManagement.Portal but am not sure how to use it. 

Can someone help me make sure the web.config does not ignore index.htm using X3 or another way?

Thanks !!

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Default DocumentDefault Document

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
Try Evoq
For Free
Start Free Trial
a Demo
See Evoq Live
Need More Information?