Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Can't get friendly URLs in 7.3.4Can't get friendly URLs in 7.3.4
Previous
 
Next
New Post
1/29/2015 7:57 PM
 

Aargh, I'm going in circles. I'm not new to DNN (been using it for years), and have a brand new DNN Community 7.3.4 website installed and running that I'm building out. I cannot for the life of me figure out where to set up the friendly URLs in the platform. All the URLs I'm getting are like:

xyz.com/Services/tabid/88/Default.aspx

I *know* I can get the non-tabid URLs and non-.aspx, because I have many other client websites on other versions of DNN 7.x that work just fine.

Losing my mind? Web.config setting? I've gone through every Host and Admin setting that I can find, and can't figure it out. 

Thanks to anyone who can point me in the right direction!

Tom

 
New Post
1/29/2015 8:22 PM
 

OK, finally figured it out. Had to change the web.config file to include the following:

<friendlyUrl defaultProvider="DNNFriendlyUrl">
<providers>
<clear />
<add name="DNNFriendlyUrl" type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" urlFormat="advanced" /
</providers>

The urlFormat was blank. "humanfriendly" works, but I still have the .aspx extension. Putting in "advanced" removed the extension. Sheesh. Wish they would make this a checkbox in the Host Settings.

 
New Post
1/30/2015 4:46 AM
 
Thomas,
please enter your suggestion in user voice module on this site.

Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group

Speed up your DNN Websites with TurboDNN
 
New Post
1/30/2015 9:17 AM
 

Thank you Sebastian, I will. 

Best regards, 

Tom

 
New Post
1/30/2015 1:17 PM
 
Thomas Petty wrote:

The urlFormat was blank. "humanfriendly" works, but I still have the .aspx extension. Putting in "advanced" removed the extension. Sheesh. Wish they would make this a checkbox in the Host Settings.

Thomas,

You indicate this is a new install of 7.3.4 How was it installed?

Just yesterday, I downloaded the DNN_Platform_07.03.04_Install.zip file from CodePlex and the friendly URL section of the web.config file is fine (has urlFormat="advanced").

I'm guessing it's incomplete is just SOME of the install versions.

 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Can't get friendly URLs in 7.3.4Can't get friendly URLs in 7.3.4


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  


Copyright 2017 by DNN Corp Terms of Use Privacy
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out