Learn More





Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Can't seem to figure out "Friendly urls"Can't seem to figure out "Friendly urls"
New Post
1/28/2015 10:39 AM

Good morning. We are upgrading from an older DNN installation to a DNN 7.3 installation. The URLs on our old site are currently ",", etc. The urls for our NEW site currently look like "". From what I can tell, all I was supposed to do was enable Friendly urls to get it to work correctly. However, friendly url's don't seem to be doing ANYTHING. They especially are not changing the urls for my webpages. The old DNN site has a "page url" section under page details, but that no longer seems to be the case.

 Am I missing something? Can somebody please point me in the right direction so I can get these short urls in place to help us mirror the old site? Thank you in advance for your time.

New Post
1/28/2015 12:00 PM

How did you activate friendly URLs?

In the web.config, there should be:

friendlyUrl defaultProvider="DNNFriendlyUrl">
clear />
add name="DNNFriendlyUrl" type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" urlFormat="humanfriendly" />


(With an open < at the start of each line.)

New Post
1/28/2015 12:42 PM
Thank you very much for your reply. I went into a section that simply had a "Use Friendly URLs" checkbox. I can't remember where and looking at the site, I am no longer able to find it. After looking on google I noticed something about "Human friendly urls"? Is that what I need to enable?
New Post
1/28/2015 2:33 PM
Hello, thank you very much for your reply. All I've done so far was click the "Use Friendly urls" checkbox because a co-worker of mine told me that was all I should have to do. I'm sorry but I don't remember where I found it and a after a quick look I was unable to find it again. After googling it appears that maybe I want to use "human friendly urls"? I'm sorry if this is such a stupid question, I've never touched DNN before a few hours ago. Thank you very much for your help.
New Post
1/29/2015 11:52 AM
I think it depends on what version of DNN you had used originally. I know that I had to add the "humanfriendly" text to my web.config when that option was first included. The content of the web.config specifies what format is used for friendly URLs.
You can turn on/off the use of friendly URLs in Host, Host Settings, Advanced (at least in DNN7).
HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...Can't seem to figure out "Friendly urls"Can't seem to figure out "Friendly urls"

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
Try Evoq
For Free
Start Free Trial
a Demo
See Evoq Live
Need More Information?