Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Language and In...Language and In...Issues with the Automated Page Localization ProcessIssues with the Automated Page Localization Process
Previous
 
Next
New Post
6/16/2014 2:23 PM
 

I am working on a site that has 3 portals and will support 16 languages.  I have set "en-US" as the fallback culture for all other languages and are using the "Localize Pages" functionality to automatically create the pages for the other cultures and copy the modules over.  More specifically, I'm using the "Create Pages in this Language" button on the Languages tab of the Languages page.  

The problem that I have run into is that modules that are marked to show on every page are being repeated many, many times.  The process worked well at first but as we have added more pages (at about 50-70 pages depending on the portal) the process has become very slow and the modules have begun to be repeated.  The localize pages process also runs very slowly (assuming this is a result of the modules being repeated).  It will complete 1 page in about 3 minutes and then never finish the 2nd page.  

The number of times that the modules are repeated varies greatly and sometimes some modules are repeated whiles others aren't.  I had one page that had 1500 modules placed on it.  There are only about 6-7 modules that are marked to be repeated on each page but one module was repeated close to 1000 times.  

Has anyone else seen this behavior before?  Does anyone has any ideas on what might be causing it? 

Any help would be GREATLY appreciated!

I can provide more specific details if needed.  We are on DNN 7.2.2 but I tried upgrading one of our environments to 7.3 to see if it would fix the issue but it did not.  

 
New Post
6/20/2014 11:36 AM
 
hmm, as far as I remember, modules that are set to display on all pages would be ignored even. This definitely sounds like a bug.

I don't think that is fixed at all, as I am not aware this was logged as a bug before. The only advice i would have right now is to stop displaying modules on all pages, create the translated versions, and then re-enable the display on all pages for modules that need it...


Erik van Ballegoij, Former DNN Corp. Employee and DNN Expert

DNN Blog | Twitter: @erikvb | LinkedIn: Erik van Ballegoij on LinkedIn

 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Language and In...Language and In...Issues with the Automated Page Localization ProcessIssues with the Automated Page Localization Process


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  


Copyright 2017 by DNN Corp Terms of Use Privacy
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out