Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Language and In...Language and In...Browser language detection still not working after upgrade to 7.2.2Browser language detection still not working after upgrade to 7.2.2
Previous
 
Next
New Post
3/20/2014 8:18 PM
 

Hi, 

I just upgraded our DNN website to the new version 7.2.2 which is supposed to resolve the browser language detection issue with advanced urls. The language detection still not working and I also try to disable and reenable the option to see if it's working but it is not. Do I forget to do something? Please help because we need this work as soon as possible. Thank you very much for help!

 
New Post
3/21/2014 5:56 PM
 
Danny;
Is this issue with specific languages or all languages you have enabled within your website?

Can you describe the advanced URL setup you have enabled on the site?

Ken Grierson
DotNetNuke Corporation
Test Lead
 
New Post
3/24/2014 6:36 PM
 

Sorry for the delay to answer. We only have 2 languages (fr-ca and en-us). The language detection doesn't work and always redirect to the English language which is the default language. This is my advanced url config in web.config file:

<friendlyUrl defaultProvider="DNNFriendlyUrl"> <providers> <clear /> <add name="DNNFriendlyUrl" type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" urlFormat="advanced" /> </providers> </friendlyUrl>

My settings for Portal Aliases in Admin Settings is the "/en-us" as primary for English and the "/fr-ca" as primary for French.

Thanks for your help!

 
New Post
3/25/2014 6:51 PM
 
Danny;
It was never fixed
I can only find this JIRA ticket on this issue https://dnntracker.atlassian.net/brow...


Ken Grierson
DotNetNuke Corporation
Test Lead
 
New Post
3/25/2014 7:18 PM
 

Hi Ken,

What I don't understand is that in the release highlights on dotnetnuke.codeplex.com, we can see "fixed issue where Language detection was not working with advanced URL management". I was thinking that will be the resolution of the issue but not seems to work. Do you have an idea of when this issue will be resolved?

Thanks for your time, it's really appreciated!

 
Previous
 
Next
HomeHomeUsing DNN Platf...Using DNN Platf...Language and In...Language and In...Browser language detection still not working after upgrade to 7.2.2Browser language detection still not working after upgrade to 7.2.2


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  


Copyright 2017 by DNN Corp Terms of Use Privacy
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out