Learn More





Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...7.1: Secondary portal alias always being redirected to Default alias7.1: Secondary portal alias always being redirected to Default alias
New Post
8/6/2013 7:40 AM


I have a DNN 7.1  install with a single portal that now has two aliases   (Default)

Whenever I try to browse to I am always 301 redirected to

I saw elsewhere that someone suggested changing the urlFormat in the DNNFriendlyUrl section of the webconfig file to humanfriendly. However this also globally changes all of my page Urls. As the website is in production this is a big problem

Can anyone please help. This is quite urgent.

Thanks in advance for any help given


New Post
8/7/2013 9:56 AM
check website alias section in website settings and make sure you are using canonical instead of redirect.

Cheers from Germany,
Sebastian Leupold (Microsoft MVP)

dnnWerk - The DotNetNuke Experts   German Spoken DotNetNuke User Group   European Network of DotNetNuke Professionals

Speed up your DNN Websites with TurboDNN
New Post
8/13/2013 5:42 AM

Hi Tony/Sebastian,

I'm in exactly the same situation here and can't seem to get this resolved. I've never found this with any pre-7.1 sites that I've configured in exactly the same way.

Tony - can you confirm that these two changes have worked for you?

Sebastian - is your suggested canonical/redirect change intended to solve Tony's original issue (the redirect to the default alias) or purely to deal with the change in URL's caused by the switch to the humanfriendly urlFormat?

Thanks in advance guys, I'm glad I'm not alone with this issue!


New Post
8/23/2013 11:37 AM
I have the same issue here but on 7.04.
I decided to test this feature so i set my test_alias as default one and mapping mode to redirect. it started redirecting me from localhost to test_alias as expected. However when I changed it back to canonical it still keeps redirecting. When I changed default to localhost and set it again to redirect mode it would then start redirecting the other way (from test_alias to localhost).
localhost is on my local pc and test_alias is on external server. They share same database. Database entries change correctly as I change modes.

Does anyone have any idea how to stop it from redirecting when not in redirect mode?

Thanks in advance.
New Post
9/3/2013 8:21 AM

Hi Sebastian,

Sorry for the delay in getting back to you but I did not receive any notification that any replies had been made to my post.

I had canonical set and the alias was also correctly set. I also tried setting the Sitealias mode to "None" but that didn't help.

In the end I had to use the humanfriendly setting and accept the changes to URL's but I would love to get the advanced URL facility working as I think it is a very important improvement to DNN. Almost all of my customers do not want the .aspx extensions in the URLs and the smarter ones say "We can do this in Wordpress", reagrdless of the fact that DNN is easy for them to use. 





HomeHomeUsing DNN Platf...Using DNN Platf...Administration ...Administration ...7.1: Secondary portal alias always being redirected to Default alias7.1: Secondary portal alias always being redirected to Default alias

These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.
Try Evoq
For Free
Start Free Trial
a Demo
See Evoq Live
Need More Information?