Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeDevelopment and...Development and...Building ExtensionsBuilding ExtensionsModulesModulesDropping a control onto the page, intellisense not working???Dropping a control onto the page, intellisense not working???
Previous
 
Next
New Post
5/6/2013 8:54 AM
 

I'm developing a module.  In my VS Toolkit, I have included a 3rd party control suite.  When I drop one of the controls onto my page, I notice the squiggly lines under the control and the lack of intellisense.  I'm developing using VS2012 against a DNN 7.0.005 installation on my local PC.

I've verified that the DLL is being referenced in the project and I get no build errors.  I've restarted my project several times.  From my code-behind, I can see the controls and work with the properties.  Does anyone know what would prevent one from being able to simply drop a control onto a page and not have it be accessible through the intellisense?

 

 

 
New Post
5/6/2013 9:33 AM
 
Richard,

this seems to be a VS 2012 issue. I hardly use the designer view, but in markup, intellisense is not working in the ascx file - although, it works well in the code behind file.

Even with Update 2 this was not solved, and all the discussions about it here, on the asp.net forums, on stackoverflow etc. do not bring a solution (at least not in my case, or only temporarily...)

Best wishes
Michael

Michael Tobisch
DNN★MVP
dnn-Connect.org - The most vibrant community around the DNN-platform
 
New Post
5/6/2013 9:36 AM
 
Hi Richard,

please check if the the third party assembly is registered in your ASCX or not.

Cheers..!!!

Amit Mohanty
Mindfire Solutions
 
New Post
5/6/2013 9:41 AM
 

It is registering in my ASCX page.  It just won't recognize the controls in the designer.  I've tried everything.

 

 
New Post
5/6/2013 9:42 AM
 
Thanks for the reference to the other discussion, Michael.  I've been going crazy wondering what I had done wrong.  I appreciate the info!
 
Previous
 
Next
HomeHomeDevelopment and...Development and...Building ExtensionsBuilding ExtensionsModulesModulesDropping a control onto the page, intellisense not working???Dropping a control onto the page, intellisense not working???


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  


Copyright 2017 by DNN Corp Terms of Use Privacy
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out