Welcome to the DNN Community Forums, your preferred source of online community support for all things related to DNN.
In order to participate you must be a registered DNNizen

HomeHomeDevelopment and...Development and...Building ExtensionsBuilding ExtensionsModulesModulesnavigate url failing to return domainnavigate url failing to return domain
Previous
 
Next
New Post
4/24/2013 11:55 AM
 
Sorry/Glad someone else is experiencing this issue.
The navigateUrl function is now (recent) failing for my custom dnn module.
I do not see what has changed.
I do see that if url is in form

https://myDnnDomain.com/childPortalName/Home/tabid/10667/Default.aspx

instead of

https://myDnnDomain.com/Home/tabid/10667/Default.aspx

the navigateUrl will return the domain as needed.

So navigateUrl(tabId) will return "/Home/tabid/10667/Default.aspx" if the url does not have the portal name/child name

This is a large problem.
 
New Post
5/28/2013 5:28 PM
 
I am sorry, i don't understand what you mean here. Can you try to be a bit more clear about what your problem is exactly?

Erik van Ballegoij, Former DNN Corp. Employee and DNN Expert

DNN Blog | Twitter: @erikvb | LinkedIn: Erik van Ballegoij on LinkedIn

 
New Post
5/29/2013 8:00 AM
 
I have a custom module that sends email that includes a link back to a page in the site. To form the link, I used the navigateurl function. This worked for five years or so without issue. Just recently I have reported failures in that if the page that posts the request has a url in the form of

https://myDnnDomain.com/Home/tabid/10667/Default.aspx

navigateUrl will return /Home/tabid/10667/Default.aspx instead of the entire url.

navigateUrl will only return the entire url if the page that posts th request has a url in the form of

https://myDnnDomain.com/childPortalName/Home/tabid/10667/Default.aspx


I do not know what changed as I did not recently change friendly url settings etc. The mother (500+ child portals) has been running with little change to host settings for beyond the 5 years that this module has been in place.

I have coded around the issue by checking the url for the existance of the domain and inserting if not.
 
Previous
 
Next
HomeHomeDevelopment and...Development and...Building ExtensionsBuilding ExtensionsModulesModulesnavigate url failing to return domainnavigate url failing to return domain


These Forums are dedicated to discussion of DNN Platform and Evoq Solutions.

For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
  4. No Flaming or Trolling.
  5. No Profanity, Racism, or Prejudice.
  6. Site Moderators have the final word on approving / removing a thread or post or comment.
  7. English language posting only, please.

Content Layout

Subscribe to DNN Digest

Subscribe to DNN Digest

DNN Digest is our monthly email newsletter. It highlights news and content from around the DNN ecosystem, such as new modules and themes, messages from leadership, blog posts and notable tweets. Keep your finger on the pulse of the ecosystem by subscribing.  


Copyright 2017 by DNN Corp Terms of Use Privacy
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out
What is Liquid Content?
Find Out